Kantata OX Slowness
Incident Report for Kantata OX
Resolved
The slowness that being experienced in Kantata OX is now resolved. Thank you for your patience.
Posted Jan 11, 2024 - 12:39 PST
Investigating
We are experiencing intermittent slowness across the application. We are currently working on a fix. If you experience a failure to load, please wait one minute and try to refresh. Thanks for your understanding.
Posted Jan 11, 2024 - 11:49 PST
This incident affected: Kantata OX Application.