Problems With Creating and Updating Projects
Incident Report for Kantata OX
Resolved
We have identified the problem and have released a fix to allow creating and updating projects once again. Thank you for your patience.
Posted Feb 05, 2024 - 12:31 PST
Investigating
We are currently experiencing problems creating and updating projects. We appreciate your patience as we investigate this issue.
Posted Feb 05, 2024 - 12:13 PST
This incident affected: Kantata OX Application.