OX Customer Support Portal Outage
Incident Report for Kantata OX
Resolved
The OX Customer Support Portal is now available. Thank you for your patience.
Posted Jul 08, 2024 - 13:04 PDT
Investigating
We are currently experiencing an outage with the OX Customer Support Portal. The issue has been identified and we're working as fast as possible to resolve. If you need immediate assistance from Kantata Support please contact us via our 24/7 live chat.
Posted Jul 08, 2024 - 08:24 PDT