Kantata Application Offline
Incident Report for Kantata OX
Resolved
The application is now functioning normally. If you are still having issues loading the site, restart your browser completely.
Posted Mar 08, 2024 - 13:46 PST
Update
We are continuing to work on a fix for this issue.
Posted Mar 08, 2024 - 13:45 PST
Identified
We are aware of the issue with the Kantata application and the application will be back online shortly.
Posted Mar 08, 2024 - 13:32 PST
This incident affected: Kantata OX Application.